apt upgradeしようとしたら/var/lib/dpkg/lock-frontend が取得できませんでしたというメッセージが表示される

2020-02-09

apt upgradeしようとしたら/var/lib/dpkg/lock-frontend が取得できませんでしたというメッセージが表示される

このエントリーをはてなブックマークに追加
sudo apt upgrade

と実行し、パッケージを更新しようとしたら

E: ロック /var/lib/dpkg/lock-frontend が取得できませんでした - open (11: リソースが一時的に利用できません)

というメッセージが表示されてなぜか中断されてしまう。

解決

とりあえず該当のロックファイルを削除して対応しました。

sudo rm /var/lib/dpkg/lock-frontend

これで難なくパッケージはいつもどおり更新できるようになったが、そもそもなぜこういった症状になってしまうのかはわかりませんでした・・・。

Ubuntuのソフトウェアアップデータ−とターミナルのパッケージ更新を併用していたり、更新中にもしかしたらOS再起動していたかもしれないなど、諸々の原因はありそう。