「composer self-update」を実行するとエラー

2019-10-27

「composer self-update」を実行するとエラー


このエントリーをはてなブックマークに追加

久しぶりに「composer self-update」を実行すると下記のようなエラーがでてきた。

 [RuntimeException]                                                                           
  SHA384 is not supported by your openssl extension, could not verify the phar file integrity 

解決方法

composerを再インストールしよう。

composerを削除、直接composer.pharを使っている人はそれを削除

sudo rm -rf /usr/local/bin/composer

composer.pharを落としてくる

sudo curl -s https://getcomposer.org/installer | php

composer.pharを移動

sudo mv composer.phar /usr/local/bin/composer

これで問題なく使えるようになるはず。