PHP5.3以降から追加されたDoS攻撃回避用のmax_input_varsとかいうパラメータ


max_input_varsというのはWebアプリケーションのリクエスト数を制限するパラメータでデフォルトの設定が1000になっている。

例えば顧客データが1000人以上あってそれらの情報を一括で更新しようとした場合に起こりやすい。

そんなWebアプリが昔のコードだと存在するらしい・・・というか最近目の当たりにしたわ。

とりあえずPHPのバージョンを5.3に上げて「あれ?動かないな・・・?」ってことがあったらphp.iniの設定を疑ったほうがいい。

ただこんなコードは書きなおす方が最善だと思うが・・・。

[php]

max_input_vars = 1000

[/php]


この投稿へのコメント

コメントはありません。

コメントを残す

この投稿へのトラックバック

トラックバックはありません。

トラックバック URL